Ask Your Question
1

puppet on windows: agent first run requires .NET 3.5

asked 2013-11-04 10:52:15 -0500

slthomason gravatar image

After installing puppet onto Windows Server 2012 R2 vanilla install (nothing changed after install but some basics to work with vagrant) I install and manually run the Puppet Agent and am met with a Windows Feature pops up with an error message:

The following feature couldn't be installed: .NET Framework 3.5 (includes .NET 2.0 and 3.0) ....

Any ideas? This is with Puppet 3.3.1 .... is .NET required now?

edit retag flag offensive close merge delete

Comments

Are you perhaps calling through cygwin?

rob gravatar imagerob ( 2013-11-13 15:14:05 -0500 )edit

nope - no cygwin even installed on the box.

slthomason gravatar imageslthomason ( 2013-11-13 15:30:29 -0500 )edit

Joshc's answer is the reason. If you try to use "Run Facter" or "Run Puppet Agent" it will call the elevate.exe program, which requires this, but "Start Command ...(more)

rob gravatar imagerob ( 2014-03-14 14:25:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-11 12:59:43 -0500

joshc gravatar image

updated 2014-05-14 01:15:55 -0500

The elevate.exe program that is used to interactively launch puppet & facter has a dependency on .NET 3.5. If you manually try to run puppet or facter using the shortcut, it can trigger the install dialog. See https://tickets.puppetlabs.com/browse... .

edit flag offensive delete link more

Comments

Manually running puppet agent would or would not trigger this behavior?

rob gravatar imagerob ( 2013-11-13 15:14:30 -0500 )edit

I can confirm that I'm having the same behavior. From a clean Windows Server 2012 R2 Build, if I run Puppet Agent as an Administrator, I see the dependency ...(more)

sav2880 gravatar imagesav2880 ( 2014-02-19 15:56:46 -0500 )edit

Ah, that could be the issue. I usually don't run with UAC turned on, thus I would not see this behavior.

rob gravatar imagerob ( 2014-02-21 11:32:20 -0500 )edit

This should no longer be an issue - if you are running into this on older agents, you can just add a small file next to the elevate.exe file in the puppet install directory named elevate.exe.config - https://raw.githubusercontent.com/puppetlabs/puppet-win32-ruby/1.9.3/tools/bin/elevate.exe.config

rob gravatar imagerob ( 2014-09-15 14:42:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-04 10:52:15 -0500

Seen: 687 times

Last updated: May 14 '14