Upgrade error

asked 2013-11-05 09:04:17 -0600

braunmiller gravatar image

updated 2015-04-04 11:03:19 -0600

Hi,

we are running Puppet Enterprise 2.5.3 and want to upgrade to the latest version. So we decided to start small and upgrade from 2.5.3 to 2.6.0. But when we run puppet-enterprise-upgrader on the puppet master (Amazon AMI 2013.09) the upgrade process stops with the following errors:

Transaction check error:
  file /opt/puppet/share/puppet-dashboard/public/stylesheets/sass conflicts between attempted installs of pe-puppet-dashboard-baseline-2.0.5-1.pe.el6.noarch and pe-puppet-dashboard-1.2.10-2.pe.el6.noarch
  file /opt/puppet/share/puppet-dashboard/config/initializers conflicts between attempted installs of pe-console-auth-1.1.4-1.pe.el6 ...
(more)
edit retag flag offensive close merge delete

Comments

Hi, seems like a conflicting file error. What does your last run logs or any logs from /var/log puppet says?

Anandk gravatar imageAnandk ( 2015-12-16 21:00:26 -0600 )edit