Ask Your Question
0

Connection error. We could not find classes on your master.

asked 2013-11-08 05:20:49 -0500

neumerance gravatar image

updated 2013-11-08 05:21:43 -0500

I am a newbie using puppet.

I have 2 questions.

What I want to do is to deploy openstack multi-node using puppet enterprise I have managed to install openstack-puppetlab module using "puppet module install puppetlabs/openstack" on "/etc/puppetlabs/puppet/modules". My question now is, Do this modules should be display in class list?

I got the below error instead.

image description

My 2nd question is.

How and where could I able to put my openstack hiera yaml file for openstack if I am running puppet master node under ubuntu platform?

hiera yaml file : https://gist.github.com/ody/5718115

I hope ... (more)

edit retag flag offensive close merge delete

Comments

For the 1st part, can you check and see if you have any classes that contain non-UTF-8 characters?

Celia gravatar imageCelia ( 2013-11-11 18:46:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-11-09 09:05:56 -0500

keshab gravatar image

Run

#puppet config print |grep "modulepath"

to see if modulepath variable is pointing to right path for openstack module

and you should see log for error.

edit flag offensive delete link more

Comments

thanks, I will check that later. I would like to ask follow up question. Does ubuntu 12.04 is supported by puppetlabs to deploy openstack? or I need to use CentOS?

neumerance gravatar imageneumerance ( 2013-11-10 20:26:03 -0500 )edit

I am having the same problem but with an apache module. I checked the modulepath variable and it is pointing to right module path. I am also getting the below ...(more)

triceras gravatar imagetriceras ( 2013-11-14 21:28:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-11-08 05:20:49 -0500

Seen: 477 times

Last updated: Nov 09 '13