Ask Your Question
0

Puppet Install - PostgreSQL server failed to start

asked 2013-11-12 18:15:55 -0600

jhoug gravatar image

Hi,

I'm new to Puppet and I'm attempting to install the following Puppet components on my Linux RHEL6 server:

  • Puppet Master
  • PuppetDB
  • Console
  • Puppet Agent

After the process gets past the point where all of the packages are installed and dependencies resolved, the install fails with this message:

Complete!

Preserving existing auth.conf

Setting up puppet master...

Checking the agent certificate name detection...

Setting up the database...

Configuring postgresql server... PostgreSQL server configured. !! ERROR: The PostgreSQL server failed to start; unable to proceed

I've performed the Puppet uninstall and removed postgresql from my server several times with ... (more)

edit retag flag offensive close merge delete

Comments

When you removed the postgresql did you purge it or just uninstall ? I would recommend to purge it and make sure to remove all stale configuration files and restart again.

golja gravatar imagegolja ( 2013-11-13 08:10:43 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-11-20 17:13:12 -0600

jhoug gravatar image

Hi,

I've gotten around this problem by installing and manually setting up the PostgreSQL DB before running the Puppet installer. Once by PostgreSQL DB has been setup properly, I then run the Puppet installer and NOT select the "Install PostgreSQL DB" option.

Thanks,

edit flag offensive delete link more
0

answered 2013-11-13 11:14:25 -0600

jhoug gravatar image

Hi,

Thank you for the suggestion. When I manually remove "postgresql", I use the following commands:

rpm -e --nodeps pe-postgresql-9.2.4-6.pe.el6.x8664 rpm -e --nodeps pe-postgresql-server-9.2.4-6.pe.el6.x8664 yum remove postgresql yum erase postgresql

Once I've performed the above commands, there are no references to "postgresql" on my server. Is there an additional step that is required to "purge" postgreSQL? In addition, I manually remove the following Puppet files and directories:

/opt/puppet /etc/puppetlabs /etc/init.d/pe-* /var/log/pe-*

Once I've performed the above steps, I rerun ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-12 18:15:55 -0600

Seen: 867 times

Last updated: Nov 20 '13