Ask Your Question
1

PE mcollective, no client.cfg

asked 2013-11-14 17:37:43 -0500

Forrest gravatar image

I read in the documentation about this common error:

You've enabled the ssl security provider, which implies each user will have their own ssl credentials to use in the collective. In order to avoid incomplete configuration of clients in this mode we delete the system-wide /etc/mcollective/client.cfg and only generate user configuration files with the mcollective::user definition.

Okay, fine -- but how do I either fix this or use MCO on the CLI? I don't see this mentioned. Do I need to manually generate configs for use with MCO on each host I deploy? (that doesn ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-15 16:38:57 -0500

I believe this was answered for you on the mailing list, but I'm going to paraphrase Ben Ford's reply here in case other people search for the same thing. In Puppet Enterprise, you'll need to run mco commands as the peadmin user (su --peadmin). More information on using mcollective in PE can be found here: http://docs.puppetlabs.com/pe/latest/orchestrationinvokecli.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-14 17:37:43 -0500

Seen: 122 times

Last updated: Nov 15 '13