Ask Your Question
0

add classes shows me connection error in web UI

asked 2013-11-16 06:33:46 -0600

vrajkumar gravatar image

updated 2013-11-16 06:34:40 -0600

in the puppet dashboard production log I saw

Connecting to database specified by database.yml

Problem loading console auth middleware: cannot load such file -- consoleauthmiddleware Problem with loading console: cannot load such file -- consolemiddleware Problem with loading console auth: cannot load such file -- consoleauthappmiddleware Problem with loading event inspector: cannot load such file -- eventinspectormiddleware Problem with loading live management: cannot load such file -- live_management

how to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-22 08:40:12 -0600

CarlP gravatar image

I had the same issue and managed to resolve it thanks to a few posts I read from others.

The problem manifested itself in the syslog log as "....invalid byte sequence in US-ASCII at /etc/puppetlabs/puppet.....". There were many of these throughout the log so I pulled-out the guilty parties with:

grep invalid byte sequence in US-ASCII syslog | grep \.pp | awk '{print $12}' | uniq -u

This is the list I got back:

/etc/puppetlabs/puppet/modules/openstack/manifests/controller.pp /etc/puppetlabs/puppet/modules/swift/manifests/storage/filter/recon.pp /etc/puppetlabs/puppet/modules/swift/manifests/storage/filter/healthcheck ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-16 06:33:46 -0600

Seen: 148 times

Last updated: Mar 22 '14