Ask Your Question
0

NFS Mount: Still the error Could not evaluate: Field 'device' is required

asked 2013-11-18 06:27:34 -0500

dklueh gravatar image

updated 2013-11-24 20:16:23 -0500

Stefan gravatar image

Hi there! I have still a problem in using the pupppet mount-module.

Master 3.3.2 on Ubuntu 12.04 LTS 64 bit. Agent with problem: SLES 10 SP2 64 Bit with Agent 2.7.21

The mount should be created by the following:

file { '/opt/Logfiles':
  ensure => directory,
  notify => Mount ['/opt/Logfiles'],
}

mount { "/opt/Logfiles":
  name        => "/opt/Logfiles",
  ensure      =>  "present",
  atboot      => "true",
  blockdevice => "-",
  device      => "logserver1:/LOG1/Logfiles",
  fstype      => "nfs",
  options     => "defaults",
  require     => File ['/opt/Logfiles'],
}

On the client the following error is shown:

puppet agent --verbose --onetime --no-daemonize
info: Retrieving plugin
info: Loading facts in /var/lib/puppet/lib ...
(more)
edit retag flag offensive close merge delete

Comments

can you post a puppetrun with the additional `--debug` option? Is it possible that you have invalid entries in your `/etc/fstab`?

Stefan gravatar imageStefan ( 2013-11-24 20:20:43 -0500 )edit

Hi Stefan! No error during debug- and the fstab is simply correct-

dklueh gravatar imagedklueh ( 2013-11-25 03:19:33 -0500 )edit

Hi Stefan, you were partial right- there was a mistake in the /etc/fstab! But It was a blank in the 3rd line- as first sign... what a bullshit! One ...(more)

dklueh gravatar imagedklueh ( 2013-11-29 02:19:37 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-11-25 14:07:54 -0500

Stefan gravatar image

I asked for debug because it looks like the resource you want to apply is not the problem and the error is triggered when the target is flushed. This indicates ... (more)

edit flag offensive delete link more
0

answered 2016-02-24 08:15:00 -0500

bschonecker gravatar image

I know I'm late to the party on this one but I had space character in the first column of my /etc/fstab file that caused this very problem.

edit flag offensive delete link more
0

answered 2013-11-18 12:49:11 -0500

rjc gravatar image

Please drop blockdevice as, following official Puppet documentation:

blockdevice
(Property: This attribute represents concrete state on the target system.)

The device to fsck. This is property is only valid on Solaris, and in most cases will default to the correct value.

Also, you might want to add dump and pass options.

P.S. Since you provide the full path in mount, name becomes redundant.

P.P.S. Please, indent the code, using markdown, next time - it will be more readable :^)

Hope this helps.

Regards,

rjc

edit flag offensive delete link more
0

answered 2013-11-19 03:04:51 -0500

dklueh gravatar image

Thanx for your answer - but I still get the error:

Could not evaluate: Field 'device' is required

edit flag offensive delete link more

Comments

Could you provide the current `mount` options, please?

rjc gravatar imagerjc ( 2013-11-19 18:49:09 -0500 )edit

what do you mean with current? The options from a nfs wich is already mounted?

dklueh gravatar imagedklueh ( 2013-11-25 03:20:40 -0500 )edit

Could you paste your modified manifest, please?

rjc gravatar imagerjc ( 2013-11-25 07:26:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-18 06:27:34 -0500

Seen: 912 times

Last updated: Nov 24 '13