Ask Your Question
0

issue running puppet on some SUSE 10 and 11 hosts.

asked 2013-11-21 10:07:58 -0500

BenL gravatar image

updated 2013-11-25 14:37:02 -0500

Stefan gravatar image

I am having issues which only happen on puppet clients running on SOME but not all SLES 10 and 11 hosts. I get the following error when trying to run the puppet client.

puppetd -t -vv server=myserver.mydomain.com 
info: Retrieving plugin
info: Loading facts in pe_version
info: Loading facts in root_home
info: Loading facts in puppet_vardir
info: Loading facts in facter_dot_d
info: Loading facts in pe_version
info: Loading facts in root_home
info: Loading facts in puppet_vardir
info: Loading facts in facter_dot_d
err: Could not run Puppet configuration client: Could not retrieve local facts: undefined method `downcase' for false ...
(more)
edit retag flag offensive close merge delete

Comments

Can you please run with the `--trace` option, e.g. `puppet agent -t -v --server=myserver.mydomain.com --trace`? This should give us a nice backtrace so we know where ...(more)

Stefan gravatar imageStefan ( 2013-11-25 14:44:46 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-09 11:13:39 -0500

I had the same issue. The problem appeared after puppetlabs-stdlib upgrade from 3.0.0 to 3.2.0. To solve issue please upgrade your facter to 1.7

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-21 10:07:58 -0500

Seen: 144 times

Last updated: Dec 09 '13