Ask Your Question
1

puppet module fails to connect to forge, the SSL CA is invalid

asked 2013-02-06 18:08:06 -0500

Remus gravatar image

updated 2013-02-07 11:03:23 -0500

OS X 10.8.2, puppet 3.1.0

puppet module install puppetlabs-nginx --modulepath modules
Notice: Preparing to install into /.../modules ...
Notice: Downloading from https://forge.puppetlabs.com ...
Error: Could not connect via HTTPS to https://forge.puppetlabs.com
  Unable to verify the SSL certificate
    The certificate may not be signed by a valid CA
    The CA bundle included with OpenSSL may not be valid or up to date

Visiting https://forge.puppetlabs.com in browser works fine. I even added the Geo Trust SSL CA root certifictae explicitly into the keychain to no avail.

edit retag flag offensive close merge delete

Comments

for the moment I'm able to overcome this by adding in ~/.puppet/puppet.conf an explicit module_repository = <a href="http://forge.puppetlabs.com%60">http://forge.puppetlabs.com

Remus gravatar imageRemus ( 2013-02-06 18:32:22 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-02-07 11:32:21 -0500

cprice404 gravatar image

Hopefully there is a way that we can fix this on our end, but as a workaround I've heard a few users say that rebuilding your rvm ruby (or reinstalling rvm altogether) seem to solve this problem:

http://kleinmann.org/2013/01/09/puppet-openssl-osx.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-06 18:08:06 -0500

Seen: 1,993 times

Last updated: Feb 07 '13