Ask Your Question
1

How to add phpmyadmin module with apache2 service?

asked 2013-12-02 18:25:21 -0500

MrBill gravatar image

updated 2013-12-03 13:10:15 -0500

I added phpmyadmin module and starting the apache service now generates an error.

Execution of '/etc/init.d/apache2 start' returned 1:

Using ssh the apache service is started and can be restarted successfully.

The problem seems related to the following in the phpmyadmin configuration:

 file 
    { 
        "/etc/apache2/conf.d/phpmyadmin.conf":
            ensure => link,
            target => "/etc/phpmyadmin/apache.conf",
            require => Package['apache2', 'phpmyadmin'],
            notify => Service["apache2"],
      }

Removing this enables apache to re-start without the puppet errors, but phpmyadmin is not configured.

Setting File['/etc/apache2/conf.d/phpmyadmin.conf'] subscription in the apache service configuration also doesn't help.

Any ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-04 11:31:46 -0500

ramindk gravatar image

I'd suspect an ordering problem in your manifest.

In the example about your phpmyadmin.conf file requires Apache and phpmyadmin. However it's possible that PHP might not be installed when that file is create and Apache is restarted. At some point afterwards PHP is installed and Puppet exits. Then you restart from the CLI and everything works fine.

I couldn't say for certain what the ordering problem is, but if Puppet work normally the second time I'd start looking for packages that the vhosts need as the culprit.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-02 18:25:21 -0500

Seen: 397 times

Last updated: Dec 04 '13