Ask Your Question
0

Puppet talks to the wrong puppet master [closed]

asked 2013-12-16 06:56:31 -0500

robrwo gravatar image

We have an test Puppet Enterprise installation, with a master at "puppetmaster".

Now we are trying to set up the live PE installation, with the master at "pmaster". But when we run puppet agent -t, it insists on talking to the "puppetmaster" server instead of "pmaster", and of course, gets SSL certificate errors.

We've thoroughly checked the configuration and can find nothing referring to "puppetmaster". Is the name "puppetmaster" baked into PE somewhere? Or is there an undocumented/poorly-documented setting for the name of the puppet master?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by robrwo
close date 2013-12-17 05:42:13.976675

Comments

I should add that the --debug option does not give any hint where it is getting this setting from. It seems to want to connect to "puppetmaster" when trying to ...(more)

robrwo gravatar imagerobrwo ( 2013-12-16 08:02:44 -0500 )edit

Furthermore, I tried hardcoding the IP address of puppetmaster to that of pmaster in /etc/hosts, and I get a "Server hostname did not master server certificate" error. So something ...(more)

robrwo gravatar imagerobrwo ( 2013-12-16 08:19:30 -0500 )edit

I've grepped everything in /etc and /var/lib and not found any reference to a "puppetmaster" server., which further leads me to believe that this is baked into Puppet somewhere.

robrwo gravatar imagerobrwo ( 2013-12-16 08:35:37 -0500 )edit

Removing the DNS entry for puppetmaster just causes Puppet to die with the error "Failed to apply catalog: getaddrinfo: Name or service not known". So again, where else might the ...(more)

robrwo gravatar imagerobrwo ( 2013-12-16 08:46:47 -0500 )edit

I've also checked all of the SSL certificates in /etc/puppetlas/puppet/ssl and none of them refer to "puppetmaster". I've also wiped the cache/state files in ...(more)

robrwo gravatar imagerobrwo ( 2013-12-16 08:58:30 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-12-17 05:41:00 -0500

robrwo gravatar image

Ok, I found the answer. In our Puppet manifests, we had

filebucket { 'main':
  server => 'puppetmaster.mydomain.example.com',
  path   => false,
}

so this was overriding the configuration. Ooops.

edit flag offensive delete link more
0

answered 2013-12-16 07:39:58 -0500

dgmorales gravatar image

Well, there's a documented setting called "server" in puppet.conf, which you can point to the server hostname. How is that set in your config?

At least in the open source version the default master name baked into puppet is "puppet". Never used much of the enterprise puppet, but this doc says the same about PE, an it seems it should ask that upon installation anyway.

edit flag offensive delete link more

Comments

It's set to the correct server, "pmaster".

robrwo gravatar imagerobrwo ( 2013-12-16 07:49:14 -0500 )edit

Question Tools

Stats

Asked: 2013-12-16 06:56:31 -0500

Seen: 1,148 times

Last updated: Dec 17 '13