Ask Your Question
0

postgresql v3.2 in PE 3.1

asked 2013-12-25 01:08:05 -0500

Hi there,

Can I upgrade the postgresql from puppetlabs to 3.2 for my PE 3.1?

When I tried to upgrade it, it says it needs v2.x of postgresql.

I want to know if they are compatible.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-27 15:27:02 -0500

reidmv gravatar image

updated 2013-12-27 15:30:03 -0500

Puppet Enterprise (PE) 3.1 classifies the host running the PostgreSQL instance used by the Console and PuppetDB using the pe_puppetdb class. As long as your database node has this classification applied, you won't be able to use the puppetlabs/postgresql 3.x module, since the pe_puppetdb module depends on puppetlabs/postgresql 2.x.

On the technical front, you should be able to de-classify your database node, which would then make it safe to install puppetlabs/postgresql 3.x. However, this move would likely complicate your upgrade path when PE 3.2 comes out in a couple of months ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-25 01:08:05 -0500

Seen: 43 times

Last updated: Dec 27 '13