Ask Your Question
0

Puppetlabs/gcc module errors

asked 2013-12-30 13:35:51 -0500

Mark Wunschel gravatar image

This morning I installed puppetlabs/gcc from Puppet Forge. I was able to add the class to my PE Console and then add it to a group I use for my agent node.

I went to do a puppet run via the command line (puppet agent -t) and I got the following error message:

Error: Execution of '/usr/bin/zypper --quiet install --auto-agree-with-licenses --no-confirm undef' returned 104: No provider of 'undef' found.

Error: /Stage[main]/Gcc/Package[undef]/ensure: change from absent to present failed: Execution of '/usr/bin/zypper --quiet install --auto-agree-with-licenses --no-confirm undef' returned 104: No provider of ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-08 19:39:44 -0500

nvpuppet gravatar image

I don't have access to a SuSE node but it looks like zypper is complaining that the package name you'd like to install conflicts with something already on the system. You might try copy/pasting the command from the zypper provider into a terminal to get more information. I suspect you may be able to get your modifications to the puppetlabs/gcc module to work by adjust the package name appropriately in params.pp.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-30 13:35:51 -0500

Seen: 121 times

Last updated: Jan 08 '14