Ask Your Question
0

broken packages while installing puppet on debian squeeze

asked 2013-12-30 14:03:29 -0500

puppenspieler gravatar image

updated 2013-12-30 14:04:05 -0500

When I try to install puppet-common on a debian squeeze, the following problems occur:

  root@squeeze:/home/mb# wget http://apt.puppetlabs.com/puppetlabs-release-squeeze.deb
--2013-12-30 20:52:19--  http://apt.puppetlabs.com/puppetlabs-release-squeeze.deb
Auflösen des Hostnamen apt.puppetlabs.com... 198.58.114.168, 2600:3c00::f03c:91ff:fe69:6bf0
Verbindungsaufbau zu apt.puppetlabs.com|198.58.114.168|:80... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 3440 (3,4K) [application/x-debian-package]
In »puppetlabs-release-squeeze.deb« speichern.

100%[========================================================================>] 3.440       --.-K/s   in 0s      

2013-12-30 20:52:20 (138 MB/s) - »puppetlabs-release-squeeze.deb« gespeichert [3440/3440]

root@squeeze ...
(more)
edit retag flag offensive close merge delete

Comments

Is there a version of puppet currently installed? How about Ruby? I'm wondering what happens if you remove either/both and let dpkg reinstall the correct dependencies.

ethrbunny gravatar imageethrbunny ( 2013-12-31 07:36:28 -0500 )edit

I think my installs are using Ruby 1.8. Can you install 'puppet-common'? what happens if you do `apt-get -f install ..`?

ethrbunny gravatar imageethrbunny ( 2013-12-31 15:38:58 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-12-31 08:17:11 -0500

puppenspieler gravatar image

updated 2013-12-31 08:18:45 -0500

puppet is not installed, ruby is not installable.

root@squeeze:/home/mb# aptitude show puppet
Paket: puppet                               
Zustand: nicht installiert
Version: 3.4.1-1puppetlabs1
Priorität: optional
Bereich: admin
Verwalter: Puppet Labs <info@puppetlabs.com>
Unkomprimierte Größe: 106 k
Hängt ab von: puppet-common (= 3.4.1-1puppetlabs1), ruby | ruby-interpreter
Empfiehlt: rdoc
Schlägt vor: puppet-el, vim-puppet

Or can you tell me which is the right ruby-package? Is it this one?

ruby1.9.1-full - Ruby 1.9.1 full installation

??

edit flag offensive delete link more

Comments

root@squeeze:/home/mb# apt-get install ruby1.9.1 Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut Statusinformationen werden eingelesen... Fertig Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass ...(more)

puppenspieler gravatar imagepuppenspieler ( 2013-12-31 08:20:29 -0500 )edit

This sort of information is usually included in the original posting. Just edit it and paste.

ethrbunny gravatar imageethrbunny ( 2013-12-31 15:36:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-30 14:03:29 -0500

Seen: 281 times

Last updated: Dec 31 '13