Ask Your Question
6

SSL cert self signed error

asked 2014-01-02 18:07:32 -0500

rroot gravatar image

updated 2014-01-02 18:09:20 -0500

Hello,

I recently attended the puppet fundamentals class and looking to turn the existing master Vbox vm we configured and used in the lab as a local master to other Vbox nodes. Every time i run a agent connection to my master with this command: puppet agent --test --server=cr.puppetlabs.vm

Blockquote

Error: /File[/var/opt/lib/pe-puppet/lib]: Failed to generate additional resources using 'eval_generate: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed: [self signed certificate in certificate chain for /CN=Puppet CA generated on classroom.puppetlabs.vm at 2013-12-10 10:42 ...
(more)
edit retag flag offensive close merge delete

Comments

Was your problem solved? If so, you should mark an answer as accepted.

spuder gravatar imagespuder ( 2014-09-29 17:58:34 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
4

answered 2014-06-26 13:48:11 -0500

updated 2014-09-29 17:54:30 -0500

spuder gravatar image

Your quickest solution is to remove the Puppet SSL directories on the Puppet clients and then regenerate the certificates again. Here's an example on the agent:

# Determine my ssldir (It's different with Puppet Enterprise, Puppet OSS or your local environment
[root@agent1 ~]# puppet agent --configprint ssldir
/var/lib/puppet/ssl
# Remove the ssl directory
[root@agent1 ~]# mv /var/lib/puppet/ssl /var/lib/puppet/ssl.old 
[root@agent1 ~]# puppet agent --test
Info: Creating a new SSL key for agent1.lab.example.org
Info: Caching certificate for ca
Info: csr_attributes file loading from /etc/puppet/csr_attributes.yaml
Info: Creating a new SSL certificate request for agent1.lab.example.org
Info: Certificate Request fingerprint (SHA256): 16:AA:BB:CC:DD:EE:FF:GG:HH:II:JJ:KK:LL:MM:NN::90:1A
Info: Caching certificate for ca
Exiting; no certificate found and waitforcert is disabled
[root@agent1 ~]#

And then on the master, sign the certificates again.

This is a common problem in desktop virtualization environments, because as we struggle to fit our VMs into our virtual lab environment the hostname for the VM can change due to our configuration, how DHCP is configured, strangeness with DNS in a VM environment, etc. For example, VMWare assigned the hostname agent1.lab.example.org.localdomain to one of my agents when I was on the train, but when I returned to the office VMWare set the hostname to be agent1.lab.example.org.

edit flag offensive delete link more
1

answered 2014-01-15 23:31:07 -0500

rjc gravatar image

Check /opt/puppet, /var/puppet, /var/lib/puppet and their subdirectories for old SSL certificates.

P.S. It might be easier to remove all packages and start afresh.

edit flag offensive delete link more
0

answered 2015-02-11 15:37:53 -0500

I have this problem on a node. I had previously used the node as a master. I uninstalled puppet and created a new certificate after re-installing. I then go to the master and sign the cert. I get this error. I do not get this error on any of my other nodes. The time on the machines is identical, and I've gone through these steps many times - erase the ssl directory on the agent, clean the cert on the master, but I always get this error.

edit flag offensive delete link more

Comments

1

Yeah i thought so too, Im playing around with creating a new Puppet Master but wanted to re-assign a node to the old Puppet Master. So the old way of clearing the /var/lib/puppet/ssl/* did not work. Then reinstalling the puppet package failed. What did work for me is removing /etc/puppet/ssl/*

Shiver1976 gravatar imageShiver1976 ( 2015-06-24 13:12:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-02 18:07:32 -0500

Seen: 19,651 times

Last updated: Sep 29 '14