Ask Your Question
1

Setup server to pull catalog with different servername

asked 2014-01-04 17:21:08 -0500

Gigi Mathews gravatar image

I have multiple dev environments which are hosted on vCloud. These environments are clones of Prod because of code restriction, i cannot change server name. Meaning, when i clone server1 from production to dev environments it would still be called server1 in those environments.

During puppet training my instructor told me that it was possible to have a server with name A talk to puppetmaster as B by updating puppet.conf . Meaning, when server1 could request catalogue from puppetmaster as serverAAA. I am unable to see hostname option in puppet.conf file. Am i looking at wrong place?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-01-05 18:22:36 -0500

ramindk gravatar image

updated 2014-01-06 05:46:32 -0500

Couple of options you can try

in your puppet.conf

[agent]
certname = someserver.example.com

However you might find it simpler to do it from the command line. I prefer this method as it's easy to pull different catalogs rather than having to edit a config file. Here are a few examples.

sudo puppet agent --certname someserver.example.com --environment stage --noop
sudo FACTER_fqdn=someserver.example.com puppet agent --server puppet.example.com

Remember that running from command line will still use any settings in your puppet.conf that you aren't explicitly setting from the command line.

EDIT ... (more)

edit flag offensive delete link more

Comments

1

Do note however that there can be weird side effects to using either approach. --certname or certname= will leave both the $fqdn and $hostname facts at their original values. FACTER_fqdn ...(more)

ffrank gravatar imageffrank ( 2014-01-06 03:01:24 -0500 )edit

Thanks for your inputs, i have made some progress, but still have couple of questions. On serverA I updated certname in puppet.conf as certname = serverB and ran puppet agent ...(more)

Gigi Mathews gravatar imageGigi Mathews ( 2014-01-09 13:25:33 -0500 )edit
1

Both work fine for me. Update your original question with the commands and logs so we can see what you're doing. Also make sure certname = is in the [agent] section.

ramindk gravatar imageramindk ( 2014-01-09 15:41:41 -0500 )edit
0

answered 2014-01-05 14:03:43 -0500

Gary Steven gravatar image

updated 2014-01-05 14:04:04 -0500

Try adding the following under [agent] in your puppet.conf on the agent node

node_name_value = ServerAAA
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-04 17:21:08 -0500

Seen: 193 times

Last updated: Jan 06 '14