Ask Your Question
0

puppet learn VM, error 400, connection refused from PuppetDB

asked 2014-01-09 10:35:27 -0500

MarcoS gravatar image

updated 2014-01-10 03:35:50 -0500

Hi, I'm trying to learn ta least the basics of Puppet through the "Learning puppet" official serie. I'm now following the server-agent examples and... I simply fail. I took a clean official exercise VM and duplicated it as per instructions at http://docs.puppetlabs.com/learning/agentprep.html Also did the customizations (loaded the indicated puppet class, modified the hosts file, checked firewalls etc). Then followed the instructions at http://docs.puppetlabs.com/learning/agentmasterbasic.html After telling the server to sign the client's certificate, the puppet agent seems to be able to connect, but ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-10 04:59:21 -0500

MarcoS gravatar image

Foudn the problem. The web service bounds itself to the address of learn.puppetlabs.vm, and as such that address must be added to the hosts file, bound to the public address. If it's not. the httpd worker will bind to 127.0.0.1 and refuse connections from the outside.

edit flag offensive delete link more

Comments

could you give an detailed description of how you solved this problem; having the same issue here and cant quite make it out what to configure to get rid of this error

kratos gravatar imagekratos ( 2014-02-15 13:08:10 -0500 )edit

i was hitting the same problem kratos. however, the symptoms were indicative of an underlying problem: i created the VM in virtualbox and used the puppet vmdk as its base ...(more)

hybby gravatar imagehybby ( 2014-03-30 19:03:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-01-09 10:35:27 -0500

Seen: 1,226 times

Last updated: Jan 10 '14