Ask Your Question
0

Error 400 on SERVER: stack level too deep on node

asked 2014-01-14 16:12:09 -0500

jdsysadm gravatar image

updated 2014-01-14 18:43:06 -0500

Stefan gravatar image

I've just built a new puppetmaster and am getting the Error 400 on SERVER: stack level too deep on node message after every run of puppet agent -t. I do have storeconfigs = true, and running Apache/Passenger with a remote puppet CA/puppetDB. However, this does not appear to be fixed by the resource.rb change. And my installed gems list is quite short, and does not include activerecord. After I restart Apache, I can run puppet agent -t exactly once, before having to restart Apache again. I have several other puppet masters running the same version of Puppet ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-14 18:51:02 -0500

Stefan gravatar image

There is a known issue in 3.2.2 that has been fixed in 3.2.3. The redmine ticket also states that the stack level too deep messages only occure after a while so that does also match with the behaviour on your machine.

edit flag offensive delete link more

Comments

No -- even upgrading to 3.4.2 fails to solve this problem. And it doesn't fail with this message "after a while", it fails after a single run of puppet agent.

jdsysadm gravatar imagejdsysadm ( 2014-01-15 12:51:15 -0500 )edit
0

answered 2014-01-15 13:25:49 -0500

jdsysadm gravatar image

I may have just stumbled onto the answer --

In my case, simply upgrading puppet-server from 3.2.2 to 3.4.2 did not work, but after I also upgraded the puppetDB from 1.3.2 to 1.5.2, the error no longer seems to be happening! At least, it hasnt happened since the puppetDB upgrade.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-14 16:12:09 -0500

Seen: 819 times

Last updated: Jan 15 '14