Ask Your Question
1

Error 400 on SERVER: Not authorized

asked 2014-01-14 17:46:05 -0500

vvz gravatar image

2 files created : file test.pp:


class copy { file {'testfile': path=> "/home/vassiliy/mytestfile", ensure=>"present", source=> 'puppet:///mpoint/client1/testfile', mode=>'644' } }


file site.pp


import "test.pp" node client1 { include copy}


in file fileserver.conf - created mountpoint like this [mpoint] path /etc/puppet/files allow *

when I'm trying to send file to remote host - client1

I got response: Not authorized to call find on /file_metadata/mpoint/client1/testfile with {:links=>"manage"}

could somebody help me with issue? or give me a link to read? thank you

edit retag flag offensive close merge delete

Comments

Which version of Puppet are you using? The configuration of `fileserver.conf` has changed with version 3. Also, what's the output of `ls -l /etc/puppet/files/client1/testfile`?

rjc gravatar imagerjc ( 2014-01-15 22:13:54 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-16 10:05:58 -0500

vvz gravatar image

Hi! I'm using puppet open source v3

ls- l gives -rwxrwxrwx for testfile , I did this intentionally yo give all perms thnx

edit flag offensive delete link more

Comments

Like I've mentioned before, things have changed in regards to fileserver.conf - please check whether your auth.conf is set up properly.

rjc gravatar imagerjc ( 2014-01-16 16:26:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-14 17:46:05 -0500

Seen: 231 times

Last updated: Jan 16 '14