Ask Your Question
0

clients not showing in console

asked 2013-02-21 11:58:55 -0600

Edward Miles gravatar image

updated 2013-02-27 08:46:43 -0600

llowder gravatar image

I am having trouble with my test configuration of Puppet Enterprise. I have Two Ubuntu Servers running Ubuntu 12.04 configured in Puppet master and Client mode. I also have a windows client which has the puppet client installed. Both Clients have appeared on the server when I run a puppet cert list and I have approved both nodes. I have tried the connection on both and both finish a catalog run in 20 seconds or under. The problem is when I try to View the agent nodes in the console they are not present and cannot be found when ... (more)

edit retag flag offensive close merge delete

Comments

Can you verify that the "reporturl = " is correct (and contains the port if necessary) in the masters puppet.conf , that the reports = https' is in the master stanza, that the ...(more)

Celia gravatar imageCelia ( 2013-02-21 12:25:14 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-10-03 17:20:23 -0600

The MCO client has gotten better Windows support in more recent versions of PE. What version of PE are you running on the agent?

edit flag offensive delete link more
-1

answered 2013-03-01 04:02:12 -0600

updated 2013-03-01 04:06:14 -0600

Actually you have to manually add the clients to the console using the right-hand side button "Add Node" present under the node count (and provide the certname).

Then you'll be able to use the dashboard as an ENC, mcollective and checks reports of puppet runs.

Screenshot

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-02-21 11:58:55 -0600

Seen: 184 times

Last updated: Oct 03 '14