Ask Your Question
1

Puppet Dashboard spool directory is using lot of space

asked 2014-01-20 21:17:54 -0500

Sunil gravatar image

Hi All,

I have a puppet dashboard instance under which spool directory is utilizing lot of space. Under this directory many reports-*.yaml files are getting generated every minute.

Path : /usr/share/puppet-dashboard/spool .

Any suggestion, if I can clear these files without breaking system. Or is there any setting I missed to configure which clears these files automatically.

Please Advise.

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2014-01-21 08:29:08 -0500

gh gravatar image

You should see a ton of Pending Tasks in your Dashboard. Those correlate to all of the files in /usr/share/puppet-dashboard/spool. If you delete them, then you lose importing those reports into your database, which might be OK, depending on your needs and retention plan. Ensure that the puppet-dashboard-workers service is running, which processes those files by importing them into the database. You may need to tune how many workers are started based on your number of CPU's.

Work through the jobs

cd /usr/share/puppet-dashboard
rake RAILS_ENV=production jobs:work

Remove them all

cd /usr/share ...
(more)
edit flag offensive delete link more
-1

answered 2014-01-22 02:08:24 -0500

Sunil gravatar image

Thanks for the help gh. This was good pointer to me.

Now I have noticed that my reports are failing while inserting into database. I got below error for many report files. Further troubleshooting we noticed that , we have already reached max value for INT to "2,147,483,641" . From lnk we came to know , we reached the max value.

Any advice will be really helpful to fix this issue.

Error found in mysql log.

,ëÂImporting report report-57584-743.yamlMysql::Error: Out of range value for column 'id' at row 1: INSERT INTO resource_statuses (failed, title, file, line, report_id, resource_type ... (more)

edit flag offensive delete link more

Comments

This is a separate issue from your original post. Recommend submitting this as a bug to the PuppetDB team.

gh gravatar imagegh ( 2014-01-23 08:13:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-01-20 21:17:54 -0500

Seen: 1,565 times

Last updated: Jan 22 '14