Ask Your Question
0

Will updating puppetlabs/postgresql in Puppet Enterprise 3 cause problems?

asked 2014-01-22 16:22:01 -0500

Puppet Enterprise 3 ships with puppetlabs/postgresql version 2.x. Will Puppet Enterprise (primarily the PuppetDB component) continue to function correctly if I add puppetlabs/postgresql version 3.x to /etc/puppetlabs/puppet/modules?

The reason behind this is to update the puppetlabs/postgresql dependency in my razorsedge/cloudera module to support puppetlabs/postgresql version 3. I just do not want to break any PE installs in the process.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-22 16:55:22 -0500

llowder gravatar image

With current versions of PE, it will cause problems and is not supported.

However, this is an issue we are aware of and have been working on, and I think PE 3.2 ( Possibly 3.3) will have the changes in them so that you can use your own version of PostgreSQL or PuppetDB modules with PE.

edit flag offensive delete link more

Comments

Is there a Redmine/Jira to track this issue?

razorsedge gravatar imagerazorsedge ( 2014-01-23 08:40:47 -0500 )edit

Unfortunately, the tickets I could find were all internal tickets, no public tickets.

llowder gravatar imagellowder ( 2014-01-23 13:40:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-22 16:22:01 -0500

Seen: 77 times

Last updated: Jan 22 '14