Ask Your Question
1

I recently upgraded PuppetDB and now I'm getting an error about log_x_deprecation_header

asked 2013-02-22 13:53:07 -0500

devicenull gravatar image

I recently upgraded PuppetDB from v0.9.1 to v1.1.1 and now I'm seeing this error in my log file:

puppet-master[9385]: Could not retrieve resources from the PuppetDB at XXXX:8081: undefined method `log_x_deprecation_header' for #<Puppet::Resource::Puppetdb:0x7f98c16ba9c0> on node XXXX

Looking at the PuppetDB log file, everything seems to be okay except for this error:

2013-02-19 16:18:57,749 WARN  [qtp1488632133-65] [http.server] Use of unversioned APIs is deprecated; please use /v1/commands

Why is puppet producing this error?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-02-24 03:16:15 -0500

Stefan gravatar image

updated 2013-09-19 04:05:00 -0500

Can you add the version of puppetdb-terminus that is installed on your master? You need to make sure the version of puppetdb-terminus matches the version of the puppetdb if you can - so double check that was upgraded also. After upgrading the terminus, ensure you restart your puppet master process.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-22 13:53:07 -0500

Seen: 480 times

Last updated: Sep 19 '13