Ask Your Question

returned 1: Error: Nothing to do

asked 2014-01-23 22:27:08 -0600

spuder gravatar image

Whenever I try and install multiple packages together, I receive the following returned 1: Error: Nothing to do

puppet apply --debug

Debug: Executing '/usr/bin/python /usr/lib/ruby/site_ruby/1.8/puppet/provider/package/'
Debug: Prefetching parsed resources for host
Debug: /Schedule[never]: Skipping device resources because running on a host
Debug: Executing '/bin/rpm -q  expat-devel xmlrpc-epi  --nosignature --nodigest --qf %{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}
Debug: Package[ expat-devel xmlrpc-epi ](provider=yum): Ensuring => latest
Debug: Executing '/usr/bin/yum -d 0 -e 0 -y install  expat-devel xmlrpc-epi '
Error: Could not update: Execution of '/usr/bin ...
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-01-24 18:07:07 -0600

spuder gravatar image

updated 2014-04-18 16:51:30 -0600

I discovered that the reason the manifest errored out, was that there was no package named xmlrpc-epi available.

I added the xmlrpc package in it's own package declaration, but it still had the same error.

  package { 'xmlrpc-epi':
    ensure  =>  installed,
    source  =>  "https://some.server/xmlrpc-epi-0.54.2-1.x86_64.rpm

I solved this by providing the name to the package

  package { 'xmlrpc-epi':
    ensure  =>  installed,
    source  =>  "https://some.server/xmlrpc-epi-0.54.2-1.x86_64.rpm",
    name    =>  'xmlrpc-epi',

Not sure why adding the name to the package fixed it.

The name needs to match whatever is returned by yum info

I've found that this doesn't work in all cases. Using the ensure_packages() function inside the puppetlabs/stdlib module is much more reliable.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-01-23 22:27:08 -0600

Seen: 4,798 times

Last updated: Apr 18 '14