Ask Your Question
0

why do I get Error 400 on SERVER: Could not find class apache for agent1.localdomain on node agent1.localdomain?

asked 2014-01-28 15:28:42 -0500

Stian gravatar image

Hi there! I'm new to Puppet and trying it out by doing the official "Learning Puppet - Basic Agent/Master Puppet". In the section "Node Definitions" where I need to put

Append this at the bottom of /etc/puppetlabs/puppet/manifests/site.pp

node 'agent1.localdomain' {

  # Note the quotes around the name! Node names can have characters that
  # aren't legal for class names, so you can't always use bare, unquoted
  # strings like we do with classes.

  # Any resource or class declaration can go inside here. For now:

  include apache

  class {'ntp':
    servers => [ "ntp1.example.com dynamic", "ntp2.example ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-01-28 16:58:55 -0500

Red Cricket gravatar image

I suspect that you haven't installed the apache module. Try installing like so ...

$ puppet module install puppetlabs/apache
edit flag offensive delete link more

Comments

ah, thank you. It works! :) I also had the same issue with ntp, but got it solved by running the same command. $ puppet module install puppetlabs/ntp

Stian gravatar imageStian ( 2014-01-29 13:47:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-28 15:28:42 -0500

Seen: 414 times

Last updated: Jan 28 '14