Ask Your Question
1

puppet returns install errors for razor module

asked 2013-02-26 11:11:08 -0500

Keith gravatar image

updated 2013-02-27 08:48:07 -0500

llowder gravatar image

I have installed puppet enterprise 2.7.1 (Puppet V2.7.19) on CentOS6 x 64. When I try to apply the razor package via "puppet apply /etc/puppetlabs/puppet/modules/razor/tests/init.pp --verbose" I get the following error:

change from absent to present faled: Execution of 'usr/bin/gem install --include-dependencies --no-rdoc --no-ri rubygems-update' returns 1: ERROR: while executing gem ... (OptionParser::InvalidOption) ... ...

Err: Could not find suitable provider for rz_image

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-06 04:56:56 -0500

Maxim gravatar image

I assume the rest of the error message mentions that --include-dependencies is not a valid option. The executable at /usr/bin/gem is provided by the OS and significantly older than the one at /opt/puppet/bin/gem.

Try and remove the OS provided rubygems package and try again. This fixed it for me.

edit flag offensive delete link more
0

answered 2013-03-05 15:14:37 -0500

Damien gravatar image

I am having the same problem. I'm thinking this has to do with the gems version. Has there been any resolutions yet?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-26 11:11:08 -0500

Seen: 180 times

Last updated: Mar 06 '13