Ask Your Question
0

Not able to install gcc

asked 2014-02-03 17:19:18 -0500

puppet911 gravatar image

Hi,

I am new to puppet and linux. I am working on exercise "Build up Environment". The exercise is to install gcc. I created a .pp file It has very simple package installation command. package{"gcc": ensure => installed, }

The command is run on virtual box running vm downloaded from puppet labs.

It throws Error: Could not autoload puppet/provider/package/rpm: No child processes.

Any help apprciated

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-03 19:48:57 -0500

spuder gravatar image

There have been a couple of reports of this bug in puppetlabs jira, and in the puppet users mailing list. They all seem to traceback to network connectivity issues.

Can you verify that your vm is able to reach the internet?


Also,package{"gcc": ensure => installed, } won't work on ubuntu.

Ubuntu & Debian have a different name for gcc than Red Hat & Centos do.

The non puppet-y way to install gcc on these OS's would be like so:

Ubuntu

sudo apt-get install build-essentials

Red Hat

sudo yum install gcc

As part of the exercise, you'll need to wrap ... (more)

edit flag offensive delete link more

Comments

You are correct it was due to internet connection. It works fine after reloading the vm. Thanks

puppet911 gravatar imagepuppet911 ( 2014-02-03 21:20:29 -0500 )edit

@puppet911 Glad to hear. Don't forget to choose the answer if it solves your question.

spuder gravatar imagespuder ( 2014-02-04 10:45:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-02-03 17:19:18 -0500

Seen: 450 times

Last updated: Feb 03 '14