Ask Your Question

Puppet agent service is not starting

asked 2014-02-07 03:10:53 -0600

david_os gravatar image

updated 2014-02-07 03:34:58 -0600

I am trying to make puppet agent run in the background and periodically check my puppet master for changes.

I kwon that I could use linux cron job to achieve this. But I think that using puppet service is better for my case. I just couldn't find any error log to start with.

root@puppettest:/# service puppet status
 * agent is not running
root@puppettest:/# service puppet start 
 * Starting puppet agent                                                 [ OK ]
root@puppettest:/# service puppet status
 * agent is not running

Here is my configuration:

root@puppettest:/# cat /etc/lsb-release 
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-02-07 08:15:52 -0600

PorkCharSui gravatar image

Hello david_os,

If the puppet agent service daemon is started, it will automatically run the agent every ~30 minutes in the background. You can configure it so it starts at system startup in /etc/default/puppet. Check if you have permissions on /var/lib/puppet/run/ to create the pid file, or perhaps an old one is preventing the creation of a new one. The agent spams your syslog if your looking for messages.

edit flag offensive delete link more

answered 2014-02-07 09:40:04 -0600

david_os gravatar image

It was in the syslog all the time :D

Will not start without authorization file /etc/puppet/auth.conf

I just need to :

root@puppettest:/# touch /etc/puppet/auth.conf

I don't know if it is a bug or a security feature, but It worked for me.

Thank you PorkCharSui and all puppet team members :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-02-07 03:10:53 -0600

Seen: 2,573 times

Last updated: Feb 07 '14