Ask Your Question

How do you install the latest stdlib module?

asked 2014-02-09 17:41:50 -0600

spuder gravatar image

updated 2014-02-09 17:47:14 -0600

While trying to install the elasticsearch/logstash module, I receive an error that my stdlib dependency is not met.

Running a fresh install of puppet enterprise 3.1.2.

puppet module install elasticsearch/logstash
Notice: Preparing to install into /etc/puppetlabs/puppet/modules ...
Notice: Downloading from ...
Error: Could not install module 'elasticsearch-logstash' (latest: v0.4.2)
  No version of 'puppetlabs-stdlib' will satisfy dependencies
    'elasticsearch-logstash' (v0.4.2) requires 'puppetlabs-stdlib' (>= 4.0.0)

It appears that puppet comes with stdlib 3.2, but elastic search requires stdlib >=4.0

When I try and upgrade to stdlib 4 ... (more)

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2014-02-10 07:54:58 -0600

elasticsearch gravatar image

updated 2014-02-22 04:08:25 -0600


Im the author of the elasticsearch modules.

It seems that Puppet Enterprise is limited to certain modules.

I'll see if stdlib 3.2 provides all the functions we require for the module so Enterprise users like you can use it.

I'll update the thread once i know more.


Update 1: Initial rspec tests are all green. Will be doing some system tests soon.

Update 2: Init system tests are running fine. Doing some more tests. If everything is positive i'll modify it to require stdlib 3.2.0 Not sure when i'll be able ... (more)

edit flag offensive delete link more


Great thanks! I'm installing log stash in a testing server, it won't be rolled into production for a little while.

spuder gravatar imagespuder ( 2014-02-11 11:27:32 -0600 )edit

Hi, I've just done system testing on PE 3.1.2 and it works like a charm. Hope to finish up my system test implementations soon and do a ...(more)

elasticsearch gravatar imageelasticsearch ( 2014-02-19 08:00:53 -0600 )edit

answered 2014-02-12 19:37:33 -0600

AronR gravatar image

updated 2014-02-18 18:21:41 -0600

As well, these commands:

puppet module install modulenamehere
puppet module upgrade modulenamehere

both accept --version= options, at least according to their help docs. That may yet make it feasible to install or upgrade to stdlib version 4.0 or higher. E.g.:

$ puppet help module upgrade
USAGE: puppet module upgrade [--force | -f]

Upgrades a puppet module.

  --version=                     - The version of the module to upgrade to.

(Am running Puppet 3.3.1, non-Enterprise, and have to date have tried this option only with puppet module install, but was successful in installing a specific version of a module ... (more)

edit flag offensive delete link more


I've been told by people from PuppetLabs that the newer stdlib is not compatible with PE 3.3.1, so not to upgrade it.

robrwo gravatar imagerobrwo ( 2014-02-19 10:10:30 -0600 )edit

answered 2014-02-14 14:38:08 -0600

elasticsearch gravatar image

updated 2014-02-18 05:23:28 -0600


New releases for ES and LS puppet modules will contain stdlib-3.2.0 as lowest version for dependency. I hope this will solve your issue soon.

Not sure yet when these will be released but keep an eye on Forge :-)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2014-02-09 17:41:50 -0600

Seen: 1,997 times

Last updated: Feb 22 '14