Ask Your Question
2

How to disable catalog caching

asked 2014-02-10 23:36:20 -0500

Thilak Raj gravatar image

Puppet agent uses the cached catalog before i get a dhcp lease and as a result the file it tries to fetch puppet://modules/<file> is failing.</file>

I was thining if caching of catalog is disabled, i will try to fetch the file only after the network connectivity is up.

Thanks in advance for your help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-06-09 20:06:14 -0500

cm01 gravatar image

I don't know when that changed, but according to that link now (10-Jun-2016) :

'This setting has no effect and will be removed in a future Puppet version.'

in case anyone else comes across this answer.

edit flag offensive delete link more
0

answered 2014-02-11 02:58:39 -0500

ramindk gravatar image

Set ignorecache = true in you puppet.conf under the [agent] section. http://docs.puppetlabs.com/references/stable/configuration.html#ignorecache

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-02-10 23:36:20 -0500

Seen: 7,255 times

Last updated: Jun 09 '16