Ask Your Question
0

Error: Failed to apply catalog: Could not find dependent File[undef] for File[passenger.conf] at /etc/puppet/modules/apache/manifests/mod/passenger.pp:37

asked 2014-02-15 02:56:17 -0500

jdehnert gravatar image

updated 2014-02-17 17:34:01 -0500

I am using the puppet labs apache module and creating the ghosts went without problems, but I have been trying to configure mod passenger and I keep getting this error

Error: Failed to apply catalog: Could not find dependent File[undef] for File[passenger.conf] at /etc/puppet/modules/apache/manifests/mod/passenger.pp:37

The error seems to be pointing at the mod directory which I defined under the apache config. I even tried commenting out my change to the mod directory, but I still get the same error.

Here is the passenger configuration...

class { 'apache::mod::passenger':
  passenger_high_performance ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-02-17 10:39:56 -0500

Ancillas gravatar image

updated 2014-02-17 10:49:11 -0500

You're calling Class['apache'], passing in a value for mod_dir that won't exist completely until Class['apache::params'] runs. i.e. Class['apache::params'] initializes apache::params::httpd_dir, but you are using apache::params::httpd_dir before the class is called.

Try overriding with a static value, or with hiera.

class {'apache':
  mod_dir => '/etc/httpd/mod.d',
}

or

class {'apache':
  mod_dir => hiera('apache::mod_dir'),
}

Ignoring the parameter bit above, you said this isn't working even if you remove your mod_dir parameter. Are you using Class['apache::mod::passenger'] before using Class['apache']? Looking at the code on github ... (more)

edit flag offensive delete link more

Comments

I was using mod_dir => '/etc/httpd/mod.d', before. I did put it back to check, same result. I have mod_dir called out in template.pp. in my node top ...(more)

jdehnert gravatar imagejdehnert ( 2014-02-17 17:30:11 -0500 )edit

Hmm, I removed mod_dir => "/etc/httpd/mod.d", completely, and I'm still getting the error. Before I added passenger into the mix, there was no problem with mod_dir.

jdehnert gravatar imagejdehnert ( 2014-02-17 18:04:14 -0500 )edit

Try adding Class['apache'] -> Class['apache::mod::passenger'] in the class where you call Class['apache'].

Ancillas gravatar imageAncillas ( 2014-02-18 11:20:47 -0500 )edit

I tried adding Class['apache'] -> Class['apache::mod::passenger'] in my web server class, but no change in behavior. I may need to abandon the puppetlabs-apache module since I can ...(more)

jdehnert gravatar imagejdehnert ( 2014-02-18 15:42:10 -0500 )edit

In the end I just decided to not use a different location for the mod_dir. Its not as clean as I would like, but it works. Running passenger from RVM ...(more)

jdehnert gravatar imagejdehnert ( 2014-03-10 16:02:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-15 02:56:17 -0500

Seen: 1,425 times

Last updated: Feb 17 '14