Ask Your Question
0

why do puppet agents complain about YAML when server is 3.4.2?

asked 2014-02-19 10:04:26 -0600

jmp242 gravatar image

updated 2014-02-19 13:30:52 -0600

I have a Scientific Linux 6.4 server running apache / passenger with puppet-server installed. Also installed is Foreman 1.4. When I upgraded my agents to 3.4.2, they started all logging: Using less secure serialization of reports and query parameters for compatibility with older puppet master. To remove this notice, please upgrade your master(s) to Puppet 3.3 or newer.

So I looked at the server, and upgraded puppet-server to puppet-server-3.4.2-1.el6.noarch I've restarted httpd (apache)...

Basically, the agents still complain. I've also updated puppet to puppet-3.4.2-1.el6.noarch no ... (more)

edit retag flag offensive close merge delete

Comments

If you do a manual run `sudo puppet agent -t` does it still log the warning? If it does not, restarting all your agents should clear that up.

llowder gravatar imagellowder ( 2014-02-19 13:51:27 -0600 )edit

It does still log the warning

jmp242 gravatar imagejmp242 ( 2014-02-19 14:28:35 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-02-21 07:59:07 -0600

jmp242 gravatar image

So this turned out to be a foreman / environment misconfiguration. Full thread here: https://groups.google.com/forum/#!topic/puppet-users/wvBHZjzkQYI

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-02-19 10:04:26 -0600

Seen: 256 times

Last updated: Feb 21 '14