Ask Your Question
1

Error when running puppet command on rhel5

asked 2014-02-24 12:03:19 -0500

Jerry Diaz gravatar image

Hi all,

I could not find an answer to my question so I am trying posting it.
I have a RHEL5 system and I would like it to join our puppet environment, but I am having some issues.

I install puppet using the following command on RHEL5:

 # gem install puppet

After a successful installation, I try to run the puppet command, and this is what I get:

# puppet
/usr/lib/ruby/gems/1.8/gems/puppet-3.1.1/lib/puppet/util/monkey_patches.rb:378: uninitialized constant OpenSSL::SSL::SSLContext::DEFAULT_PARAMS (NameError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-24 12:17:29 -0500

Stefan gravatar image

Can you please run the following from the commandline (you may have to install ruby-dev or ruby-irb to get the irb command.

% irb -ropenssl
irb(main):001:0> OpenSSL::SSL::SSLContext::DEFAULT_PARAMS
=> {:ssl_version=>"SSLv23", :verify_mode=>1, :ciphers=>"ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW", :options=>-2147480577}
irb(main):002:0>

I suspect that this will not work on your machine and this might be due to the fact that you are using the RHEL5 bundled ruby-1.8.5 while for puppet 3 you at least need ruby 1.8.7 (see docs)

The easiest way to install puppet ... (more)

edit flag offensive delete link more

Comments

Hi Stefan, Here is the output of the command:

irb -ropenssl
irb(main):001:0> OpenSSL::SSL::SSLContext::DEFAULT_PARAMS
NameError: uninitialized constant OpenSSL::SSL::SSLContext::DEFAULT_PARAMS
        from (irb):1
irb(main):002:0> exit

Jerry Diaz gravatar imageJerry Diaz ( 2014-02-24 12:50:03 -0500 )edit

That is what I expected. The SSL code has been modified because a security concern: http://projects.puppetlabs.com/issues/19151 While it has been fixed for the 2.6 ...(more)

Stefan gravatar imageStefan ( 2014-02-24 17:46:15 -0500 )edit

I installed puppet 2.7.14 and it seems to work on RHEL5.

Jerry Diaz gravatar imageJerry Diaz ( 2014-02-25 07:42:10 -0500 )edit

is this a comment about your current environment or your solution to your problem? Cause the stack trace of your question indicates that you've installed puppet 3.1.1

Stefan gravatar imageStefan ( 2014-02-25 17:14:27 -0500 )edit

True Stefan, I did not resolved my problem with version 3.1.1. I settled for 2.7.14 because it works on RHEL5.

Jerry Diaz gravatar imageJerry Diaz ( 2014-03-06 15:20:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-24 12:03:19 -0500

Seen: 208 times

Last updated: Feb 24 '14