Ask Your Question
0

Windows Agents, Puppet Enterprise - Custom RunInterval broken

asked 2014-02-28 07:54:48 -0500

ciguy gravatar image

I am getting the following in my log - Failed to determine runinterval, defaulting to 1800 seconds

This is on a windows agent. puppet --version outputs: 3.3.3 (Puppet Enterprise 3.1.1)

This is my puppet.conf contents:

[main]
server=redacted
pluginsync=true
autoflush=true
archive_files=true
archive_file_server=redacted
graph=true
environment=production
runinterval=300
edit retag flag offensive close merge delete

Comments

We may have a bug as I've noted here: http://projects.puppetlabs.com/issues/21043#note-12

rob gravatar imagerob ( 2014-03-03 07:04:38 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-02-28 09:11:32 -0500

ciguy gravatar image

I've discovered a fix for this, based on this pull request: https://github.com/puppetlabs/puppet/pull/1725

The file mentioned in the PR is present on PE, but the file PE actually uses is located at: C:\Program Files (x86)\Puppet Labs\Puppet Enterprise\service\daemon.bat

Just change rubyw to ruby in the file and this works perfectly. Obviously this would need to be done on every agent machine, so you may want to create a class to enforce this across all agents until Puppet gets around to fixing Enterprise.

edit flag offensive delete link more

Comments

This should be fixed in PE 3.4.x. See https://tickets.puppetlabs.com/browse/ENTERPRISE-312 for details.

rob gravatar imagerob ( 2014-10-03 22:59:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-02-28 07:54:48 -0500

Seen: 157 times

Last updated: Feb 28 '14