Ask Your Question
0

Migrate to puppetdb

asked 2014-03-05 12:56:59 -0500

zoredache gravatar image

I am trying to upgrade my activerecord-based storeconfigs to puppetdb. The first step I am supposed to take is to run puppet storeconfigs export. Unfortunately, this does not seem to work.

root@puppet:~# puppet storeconfigs export
Error: Unknown Puppet subcommand 'storeconfigs'
See 'puppet help' for help on available puppet subcommands
root@puppet:~# puppet --version
3.4.3

I am running a puppet 3.4.3 system, that was initially setup using 2.7. I have many exported resources, used for important systems. There would be a lot of broken things if I can't get this old storeconfig data migrated ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-05 13:54:36 -0500

Stefan gravatar image

The subcommand storeconfigs is part of the package puppetdb-terminus which has to be present in order to connect your puppet master to puppetdb. Have you already installed this one?

edit flag offensive delete link more

Comments

Thanks. I thought I had that package installed, but apparently not.

zoredache gravatar imagezoredache ( 2014-03-05 15:49:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-05 12:56:59 -0500

Seen: 194 times

Last updated: Mar 05 '14