Ask Your Question
1

I moved the production modules and the node definitions to a different directory and now puppet does not work

asked 2013-03-05 23:52:10 -0500

John1 gravatar image

updated 2013-03-06 03:25:41 -0500

domcleal gravatar image

I moved the production modules and the node definitions to /etc/puppet/prod/modules and /etc/puppet/prod/manifests/nodes I made the change in the puppet.conf but by the looks of certain commands the puppet server still shows the modules in the old places even though I changed them in the puppet.conf and restarted the puppet master process. When I run the commands below they should output /etc/puppet/prod/manifests and /etc/puppet/prod/modules because that is what I put in the puppet.conf file.

[root@ct-eng-pup puppet]# puppet agent --configprint manifestdir
/etc/puppet/manifests ...
(more)
edit retag flag offensive close merge delete

Comments

Could you reformat the last part of your post ? It's unreadble and you hardly get any answer.

ThinkBriK gravatar imageThinkBriK ( 2013-03-06 02:37:32 -0500 )edit
1

I've fixed the formatting. Two comments: a) you're using "puppet agent" to print out master related settings, use "puppet master". It isn't clear from the snippet of ...(more)

domcleal gravatar imagedomcleal ( 2013-03-06 03:30:01 -0500 )edit
1

What command are you using when you restart the puppet master? Are you sure you aren't just restarting the puppet agent? Also, What are the permissions of your puppet ...(more)

Ancillas gravatar imageAncillas ( 2013-03-06 15:34:39 -0500 )edit

I am running puppet master. the permissions on my puppet.conf file are the ones below.-rwxr--r--. 1 root root 41364 Mar 6 12:01 puppet.conf

John1 gravatar imageJohn1 ( 2013-03-06 15:49:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-06 14:05:20 -0500

John1 gravatar image

updated 2013-03-06 15:35:50 -0500

I put in the wrong commands but where it is agent or master I get the same thing, see below. [root@ct-eng-pup manifests]# puppet master --configprint manifest /etc/puppet/manifests/site.pp [root@ct-eng-pup manifests]# puppet master --configprint modulepath /etc/puppet/modules:/usr/share/puppet/modules [root@ct-eng-pup manifests]# puppet master --configprint config /etc/puppet/puppet.conf [root@ct-eng-pup manifests]# puppet master --configprint manifestdir /etc/puppet/manifests [root@ct-eng-pup manifests]#

The only thing I get when I run the puppet command " puppet agent --server ct-eng-pup.caretools.ent --test" on the agents is the below. [root@pdlnx-adpt03 ~]# puppet agent --server ct-eng-pup ... (more)

edit flag offensive delete link more

Comments

This should be a comment and not a solution.

Ancillas gravatar imageAncillas ( 2013-03-06 15:33:06 -0500 )edit
0

answered 2013-05-11 01:38:03 -0500

Do you have something like that in your config ?

[master]
 manifestdir = /etc/puppet/prod/manifests

[agent]
 manifestdir = /etc/puppet/manifests

That would explain why the puppet agent output even on the master is not what you expect...

# puppet agent --configprint manifestdir
/etc/puppet/manifests

But try :

# puppet master --configprint manifestdir

I expect :

/etc/puppet/prod/manifests

Overall the server behaves properly (see your first 'answer'), which is the most important ;-)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-05 23:52:10 -0500

Seen: 621 times

Last updated: May 11 '13