Ask Your Question
0

Module torian/ldap can't work with SSL

asked 2014-03-19 05:47:14 -0500

elric gravatar image

updated 2014-03-21 18:25:48 -0500

Thank you for your replies but as I am completely new to puppet, I do not understand completely the organization of files. I tried again and put the certificates first time in /etc/puppet/modules/ldap/files/ldap but it didn't work

So I tried again putting them in /etc/puppet/modules/files/ldap but an error displayed too (see attached image) I do not know if the problem comes from the place where I ût the files or the configuration of the module. I can deploy the LDAP server without SSL but when I want to implement SSL ... (more)

edit retag flag offensive close merge delete

Comments

From the module documentation: "Note that ssl_cert should be the CA's certificate file, and it should be located under puppet:///files/ldap/." Have you done it?

giavac gravatar imagegiavac ( 2014-03-19 09:24:40 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-03-19 22:54:55 -0500

spuder gravatar image

In order to enable ssl, you will need to put your certificates in your manifest in 'puppet:///files/ldap/' (where 'puppet:' most likely is /etc/puppet/modules/torian/ldap)

In their example their keys are master-ldap.pem and master-ldap.key

class { 'ldap::server::master':
  suffix      => 'dc=foo,dc=bar',
  rootpw      => '{SHA}iEPX+SQWIR3p67lj/0zigSWTKHg=',
  ssl         => true,
  ssl_ca      => 'ca.pem',
  ssl_cert    => 'master-ldap.pem',
  ssl_key     => 'master-ldap.key',
}
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-19 05:47:14 -0500

Seen: 108 times

Last updated: Mar 21 '14