Ask Your Question
0

cannot assign public IP in VPC with node_aws

asked 2014-03-21 04:34:38 -0500

beterthanlife gravatar image

updated 2014-03-21 04:36:44 -0500

I have installed PE with CloudProvisioner. All works well, ec2 instances are spun up in my VPC using node_aws create, however they do not have a public IP assigned.

I have tried setting associate_ public_ ip = "true" in the CloudPack::create_server() call but that hasnt made any difference. I also have "Enable DNS resolution" and "Enable DNS hostname support for instances launched in this VPC" turned on in AWS.

I know this works with the latest community edition of CloudProvisioner but I have been unable to get it to work with Puppet Enterprise. Any suggestions?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-05-01 11:50:34 -0500

elizmw gravatar image

A simple way to upgrade Fog is to run:

/opt/puppet/bin/gem install fog --no-ri --no-rdoc

edit flag offensive delete link more
0

answered 2014-03-21 07:19:22 -0500

beterthanlife gravatar image

So it turns out that Fog was the culprit, namely, the version of Fog which ships with Puppet Enterprise (1.5.0). Updating to fog v1.20.0 solves the problem.

For info, I deleted the fog-1.5.0 directory (/opt/puppet/lib/ruby/gems/1.9.1/gems/fog-1.5.0), uploaded fog-1.20.0 to the same gems directory and renamed the folder to fog-1.5.0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-21 04:34:38 -0500

Seen: 125 times

Last updated: May 01 '14