Ask Your Question
0

File transfer [puppet classes]

asked 2014-03-26 12:21:42 -0500

Anil gravatar image

Hello Team,

I have an issue with transferring files through puppet

This is the error I am receiving when puppet runs [manually-- puppet agent --test --noop] "Error: /Stage[main]/Digintp/File[/etc/ntp.conf]: Could not evaluate: Error 400 on SERVER: Not authorized to call find on /file_metadata/development/modules/digntp/ntp.conf.linux with {:links=>"manage"} Could not retrieve file metadata for puppet:///development/modules/digntp/ntp.conf.linux: Error 400 on SERVER: Not authorized to call find on /file_metadata/development/modules/digntp/ntp.conf.linux with {:links=>"manage"}"

I have provided the class that I wrote below. I ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-26 15:21:48 -0500

updated 2014-03-26 15:22:13 -0500

check in your puppet.conf your value to modulepath , probably there are modulepath in development environment and production already like this:

[development]
modulepath => $confdir/environments/development/modules
[production]
modulepath =>> $confdir/environments/production/modules

So, you don't need to specify on your source Try change your source to puppet:///modules/digntp/ntp.conf.linux and so on and probably will work :D. puppet will look in the right directory.

edit flag offensive delete link more

Comments

thank you very much this was the fix it works fine now i really appreciate the help.

Anil gravatar imageAnil ( 2014-03-26 16:37:23 -0500 )edit

welcome :D

Renan Vicente gravatar imageRenan Vicente ( 2014-03-26 20:23:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-26 12:21:42 -0500

Seen: 65 times

Last updated: Mar 26 '14