Ask Your Question
0

librarian-puppet fails to run

asked 2014-03-28 19:47:43 -0500

jplatonov gravatar image

updated 2014-03-29 00:49:45 -0500

spuder gravatar image

Hello, I what to initialize librarian-puppet and it fails with following error:

/usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- io/console (LoadError)
    from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/local/share/ruby/gems/2.0/gems/thor-0.19.1/lib/thor/shell/basic.rb:2:in `<top (required)>'
    from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /usr/local/share/ruby ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-31 04:41:01 -0500

dread gravatar image

Is this on an AWS EC2 Amazon Linux AMI?

edit flag offensive delete link more

Comments

Yes, I am using Amazon Linux and with latest updates they start using ruby2.0 Old ruby will be deprecated in next release ~ 6 month.

jplatonov gravatar imagejplatonov ( 2014-03-31 09:01:01 -0500 )edit
0

answered 2016-08-30 09:03:47 -0500

kjacek gravatar image

I have similar issue:

bundle init /usr/share/ruby/vendorruby/2.0/rubygems/coreext/kernelrequire.rb:55:in require': cannot load such file -- io/console (LoadError) from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:inrequire' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/shell/basic.rb:2:in <top (required)>' from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:inrequire' from /usr/share/ruby/vendorruby/2.0/rubygems/coreext/kernelrequire.rb:55:in require' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/shell/color.rb:1:in<top (required)&gt;'="" from="" home="" ec2-user="" .gem="" ruby="" 2.0="" gems="" bundler-1.12.5="" lib="" bundler="" vendor="" thor="" lib="" thor="" shell.rb:17:in="" <code="">shell' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/lib/bundler/ui/shell.rb:15:ininitialize' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/lib/bundler/cli.rb:13:in new' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/lib/bundler/cli.rb:13:inrescue in start' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/lib/bundler/cli.rb:11:in start' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/exe/bundle:27:inblock in <top (required)&gt;'="" from="" home="" ec2-user="" .gem="" ruby="" 2.0="" gems="" bundler-1.12.5="" lib="" bundler="" friendly_errors.rb:98:in="" <code="">with_friendly_errors' from /home/ec2-user/.gem/ruby/2.0/gems/bundler-1.12.5/exe/bundle:19:in<top (required)&gt;'="" from="" usr="" local="" bin="" bundle:23:in="" <code="">load' from /usr/local/bin/bundle:23:in<main>'

It looks like I almost fixed it somehow by executing following magic commands:

sudo yum install -y ruby20-devel gcc-c++ gem install therubyracer gem install io-console bundle init gem install bundler bundle install

Almost because I have to install: kitchen test -----> Starting Kitchen (v1.11.1)

------Exception------- Class: Kitchen::UserError

Message: You must first install the Docker CLI tool http://www.docker.io/gettingstarted/

Please see .kitchen/logs/kitchen.log for more details Also try running kitchen diagnose --all for configuration

edit flag offensive delete link more
0

answered 2014-04-01 03:15:47 -0500

dread gravatar image

updated 2014-04-01 03:19:24 -0500

OK I had exactly the same problem. The way I got around it was a little chaotic with many steps - but most of them are likely specific to *my* layout ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-28 19:47:43 -0500

Seen: 504 times

Last updated: Aug 30 '16