Ask Your Question
0

httpd failed to start due to missing .pem file

asked 2014-04-03 11:20:13 -0500

norris gravatar image

How do you generate learn.localdomain.pem which is required to start pe-httpd ?

Starting pe-httpd: Syntax error on line 8 of /etc/puppetlabs/httpd/conf.d/puppetmaster.conf: SSLCertificateFile: file '/etc/puppetlabs/puppet/ssl/certs/learn.localdomain.pem' does not exist or is empty [FAILED] Version 3.2.1 of Puppet Enterprise is available (currently 3.1.0).

Any ideas would be welcomed.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-03 12:16:39 -0500

vishwanathj gravatar image

updated 2014-04-03 12:40:32 -0500

the command line for generating the cert would be "puppet cert generate learn.localdomain" in your case

edit flag offensive delete link more

Comments

Viswanathj, thank you. That worked for me. As root I ran the command and was able to start the pe-httpd and have the puppet enterprise console running.

norris gravatar imagenorris ( 2014-04-04 04:48:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-03 11:20:13 -0500

Seen: 943 times

Last updated: Apr 03 '14