Ask Your Question

Puppet Agent for Windows does not appear in Live Management

asked 2014-04-09 14:37:54 -0500

AbdulKarim gravatar image

updated 2014-04-09 16:13:33 -0500

Hello Experts, I am a complete newbie on puppet. I have installed my puppet environment on ubuntu. Now when I install puppet agent on windows (server 2012 R2) I can see the node appear under nodes but it does not appear under live management. I have spent few days trying to troubleshoot this issue but no luck yet. My ubuntu vm is not joined to the domain, but it pings to the windows server and vice versa. I have made an entry in the host file on both the machines. It resolves to the hostname from ubuntu to windows and ... (more)

edit retag flag offensive close merge delete


I am curious to know if my suggestion below fixed your problem OR if it was something else that fixed the issue

vishwanathj gravatar imagevishwanathj ( 2014-04-14 19:10:33 -0500 )edit

This looks like there may be an issue with MCO on the agent box.

rob gravatar imagerob ( 2014-04-15 07:46:19 -0500 )edit

Thank You for your reply Vishwanath. Yes, I have got my time synced on the Linux box and my windows machine so that doesn't look like a problem. Is ...(more)

AbdulKarim gravatar imageAbdulKarim ( 2014-04-15 08:35:44 -0500 )edit

Hello Rob, This can be an issue. Can you please guide me on how can I configure mco ping on my windows/Ubuntu machine. I can however see the MCollective ...(more)

AbdulKarim gravatar imageAbdulKarim ( 2014-04-15 08:37:48 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-04-16 08:41:35 -0500

AbdulKarim gravatar image

image description

Here is the details of the mcollective log file

edit flag offensive delete link more