Class added but no packages in /opt/puppet/packages/public

asked 2014-04-09 21:01:30 -0500

aspo73 gravatar image

updated 2014-04-10 04:30:23 -0500

ffrank gravatar image

Hi there.

I've just installed Puppet Master 3.2.1 on a new Centos 6.5 VM and all looks to be working fine.

I now want to add a Redhat VM with no repo set up using the install script on the master (curl -k https://<master hostname>:8140/packages/current/install.bash | bash etc).

I've added the Class in the Puppet Console (pe_repo::platform::el_5_x86_64), and have executed a Puppet Run.

I don't see any packages created in /opt/puppet/packages/public and so the script fails from the Agent node:

Please classify ...
edit retag flag offensive close merge delete


Is the fqdn of the agent you are running on? In the PE console, have you added the pe_repo::platform::el_5_x86_64 to this node, or another one?

ffrank gravatar imageffrank ( 2014-04-10 04:32:16 -0500 )edit

Hi ffrank. Yes - all the hostnames are correctly set up, both on the host and in DNS. I have only the one host running PE Master. [root@puppet public]# hostname ...(more)

aspo73 gravatar imageaspo73 ( 2014-04-10 18:31:49 -0500 )edit

Does it work when manually invoked?

Kai Burghardt gravatar imageKai Burghardt ( 2015-04-04 09:58:11 -0500 )edit