Ask Your Question
0

The environment must be purely alphanumeric

asked 2014-04-13 05:11:17 -0500

Black Sensei gravatar image

Hello I am really really new to this so please allow my ignorance. I have installed puppet interprise 3.1.2 using puppet-enterprise-3.1.2-ubuntu-12.04-amd64.tar.gz tarball got from the site. it went really well but I didn't add any node to it. then I got an email about a new upgrade. I have been wondering how to upgrade that manually installed one till I found the url: http://docs.puppetlabs.com/guides/installation.html#debian-and-ubuntu then I discovered there is in fact a apt repository for it. I wonder why one of the resource on the ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-04-14 03:50:55 -0500

ffrank gravatar image

updated 2014-04-14 07:52:20 -0500

Hi,

visiting https://puppet:8410 with a browser is not meaningful. It's just the terminus for Puppet's RESTful API, and will answer to qualified HTTP requests from puppet agents.

The documentation you linked is indeed valid. Note that it does not include a dashboard installation and does in fact not advise you to interface to your master directly. Instead, your next step should have been to install puppet on an agent node.

To familiarize yourself better with the basic concepts of Puppet operation, I recommend to start reading at the tutorial section. You can download the image for ... (more)

edit flag offensive delete link more

Comments

Thanks for your reply, Your link sends me to the first documentation I read where I had to download the tarball manually. So what is the difference between puppet and ...(more)

Black Sensei gravatar imageBlack Sensei ( 2014-04-14 05:10:57 -0500 )edit

I updated the answer to summarize OS vs. PE.

ffrank gravatar imageffrank ( 2014-04-14 07:52:42 -0500 )edit

One more question. I think I will go back to the PE version, but is it OK to have the puppet agents on my nodes installed with the repo `apt-get install puppet` while is server is running the Enterprise version? From the documentation of PE is seems I still need the tarball event for puppet agents

Black Sensei gravatar imageBlack Sensei ( 2014-04-18 05:02:57 -0500 )edit

I don't know wether mixing PE master and OpenSource agent works. To be safe, I would use PE either everwhere or nowhere.

ffrank gravatar imageffrank ( 2014-04-19 05:41:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-13 05:11:17 -0500

Seen: 6,205 times

Last updated: Apr 14 '14