Ask Your Question
0

mariadb-server removed puppetlabs/mysql on debian [closed]

asked 2014-04-13 10:00:42 -0500

cisco gravatar image

updated 2014-04-17 05:06:10 -0500

ffrank gravatar image

Hello I'm just trying to use puppetlabs/mysql to configure a mariadb instances password and parameters, but when I declare class '::mysql::server' and try to apply the script what happens is that mariadb-server is removed and mysql-server is installed, I tried to redeclare ::mysql::server::install::name setting it to mariadb-server but I cannot redeclare that class in my script. I'm using mariadb from the official mariadb repository

Thank for your attention

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by cisco
close date 2015-10-16 20:21:09.076243

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-04-15 03:29:05 -0500

updated 2014-04-15 05:57:11 -0500

ffrank gravatar image

You've got to set mysql::params::server_package_name to the mariadb package name in your distribution.

You can use hiera or call the class via resource-like declaration :

class {'::mysql::params':
  server_package_name => 'mymariadbpackagename',
}
class {'::mysql::server':
  require => Class['::mysql::params'],
}
edit flag offensive delete link more

Comments

In the latest release, that parameter is apparently named "package_name", see https://github.com/puppetlabs/puppetlabs-mysql#package_name

ffrank gravatar imageffrank ( 2014-04-15 06:00:18 -0500 )edit

I thought cisco would use the puppet forge one. Anyway Cisco, you have to adjst the name of the parameter according to the possible parameters of ::mysql::params (have a ...(more)

ThinkBriK gravatar imageThinkBriK ( 2014-04-17 03:28:01 -0500 )edit

Hello to everyone, I think I just made it , "Server version: 10.0.10-MariaDB-1~wheezy - mariadb.org binary distribution" Thank you for your advices, in the end the solution I adopted has been the one using the "package_name" parameter

cisco gravatar imagecisco ( 2014-04-19 07:40:40 -0500 )edit
1

Then you can mark this question as answered ? :)

ThinkBriK gravatar imageThinkBriK ( 2014-04-21 07:26:42 -0500 )edit

I'm getting Error 400 on SERVER: Invalid parameter package_name Cant get to work with the latets puppetlabs-mysql module to install mariadb on ubuntu 14.04.

SupportAnddare gravatar imageSupportAnddare ( 2015-09-29 08:10:56 -0500 )edit
-1

answered 2014-04-15 04:32:45 -0500

cisco gravatar image

updated 2014-04-17 05:05:08 -0500

ffrank gravatar image

Hi ThinkBrik , thank you for your reply, I tried to follow your suggestion but my result was unexpected.

Invalid parameter server_package_name at /tmp/vagrant-puppet-1/manifests/site.pp:59 on node vbox-debian
edit flag offensive delete link more

Comments

1

As stated earlier - in the latest release, that parameter is apparently named "package_name", see https://github.com/puppetlabs/puppetlabs-mysql#package_name

ffrank gravatar imageffrank ( 2014-04-17 05:04:30 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-13 10:00:42 -0500

Seen: 490 times

Last updated: Apr 17 '14