Ask Your Question

Change user activation link

asked 2014-04-18 09:49:35 -0600

beeme1mr gravatar image

updated 2014-04-18 11:42:24 -0600

ramindk gravatar image

I've recently setup the puppet enterprise console. When I add new users, the link sent in the mail points to localhost.localdomain. How can I change the hyperlink information?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-04-18 11:32:33 -0600

updated 2014-04-18 17:02:11 -0600

In /etc/puppetlabs/console-auth there should be a file config.yml, in that file under authentication: section you will find a key named consoleabsoluteurl:, set the value of URL to your console URL.

For example, if my console is accessible for end users at "" It should look like following:


Don't forget to restart httpd.

/etc/init.d/pe-httpd restart
edit flag offensive delete link more


I've changed config.yml and restarted both pe-puppet and pe-puppet-dashboard-worker but the URL still isn't updated. Do I need to restart anything else for the change to take effect?

beeme1mr gravatar imagebeeme1mr ( 2014-04-18 12:48:30 -0600 )edit

did you restart httpd? /etc/init.d/pe-httpd restart

hameedullah gravatar imagehameedullah ( 2014-04-18 14:06:18 -0600 )edit

That was it! Thank you, sir.

beeme1mr gravatar imagebeeme1mr ( 2014-04-18 14:50:38 -0600 )edit

answered 2014-04-18 11:29:06 -0600

vishwanathj gravatar image

Go to the file located at /etc/puppetlabs/console-auth/config.yml and edit the consoleabsoluteurl attribute. I tested this and it works. Please confirm if this is what you wanted.

edit flag offensive delete link more


Did you have to restart anything for this to work?

beeme1mr gravatar imagebeeme1mr ( 2014-04-18 13:19:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2014-04-18 09:49:35 -0600

Seen: 241 times

Last updated: Apr 18 '14