Ask Your Question
0

why filebucket isn't using /etc/hosts to resolve puppetmaster's ip ?

asked 2014-04-22 09:38:54 -0500

k4cy gravatar image

updated 2014-04-22 11:27:22 -0500

spuder gravatar image

I've got a filebucket defined as :

[root@master01 puppet-dashboard]# cat /etc/puppet/manifests/site.pp
filebucket { 'main':
  server => 'puppetmaster',
  path => false,
}
File { backup => 'main' }

import "nodes"

agents running on local VMs are running OK but agents running on an external VM can't find the hosts, which is defined correctly in /etc/hosts...

edit retag flag offensive close merge delete

Comments

This might be a serverfault question rather than a puppetlabs one. In either case, need more info: What is the error you're seeing? What is your definition of external vs local VM? Output of "nslookup puppetmaster" from external VM Contents of /etc/nsswitch.conf and /etc/resolv.conf from the same

mapa3m gravatar imagemapa3m ( 2014-04-22 19:03:27 -0500 )edit

[root@frllogdev00 ~]# nslookup puppetmaster ;; Got SERVFAIL reply from x.x.x.x, trying next server ;; Got SERVFAIL reply from x.x.x.x, trying next server Local VMs are vms on the same network than the puppet master, external ones are accessing puppetmaster via proxy

k4cy gravatar imagek4cy ( 2014-04-23 03:47:43 -0500 )edit

nslookup is not the right tool for this job, because /etc/hosts is supposed to supersede or (as in this case) supplement information from DNS. Try `ping puppetmaster` instead. If it cannot resolve the name, there are issues with the hosts file. You might wish to share its contents.

ffrank gravatar imageffrank ( 2014-04-23 06:59:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-23 20:29:16 -0500

crashradtke gravatar image

updated 2014-04-23 20:31:38 -0500

It sounds like your nsswitch.conf might not be correct (for your application) [root@pptslv ~]# grep ^hosts /etc/nsswitch.conf

hosts: files dns

or - the nameserver values you have in your /etc/resolv.conf are not reachable (since the VM is "external")

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-22 09:38:54 -0500

Seen: 638 times

Last updated: Apr 23 '14