Ask Your Question
1

Installing puppetlabs-apache as described in the Quest Guide

asked 2014-04-29 05:54:55 -0500

pmichna gravatar image

updated 2014-04-29 06:13:32 -0500

I'm trying to do the tutorials from the Quest Guide. I've come to the point where I'm supposed to install the puppetlabs-apache module.

[root@learn /etc/puppetlabs/puppet/modules]# puppet module install puppetlabs-apache
Notice: Preparing to install into /etc/puppetlabs/puppet/modules ...
Notice: Downloading from https://forgeapi.puppetlabs.com ...
Error: SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol
Error: Try 'puppet help module install' for usage

For some reason this doesn't work. So I tried the offline version:

[root@learn /etc/puppetlabs/puppet/modules]# tar zxvf /usr/src/forge/puppetlabs-apache-0.8.1.tar.gz -C .

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

Is the archive broken?

edit retag flag offensive close merge delete

Comments

Did you check if your network in virtual machine is working in the first test? "puppet module install puppetlabs-apache" If it isn't working try change your network to bridge on virtual machine.

Renan Vicente gravatar imageRenan Vicente ( 2014-04-29 09:56:55 -0500 )edit

1. I can ping google.com, so I guess it works. 2. It is a bridge. 3. The problem might be with some firewall settings in my company. However, that doesn't have to do with the offline archive.

pmichna gravatar imagepmichna ( 2014-04-29 10:14:21 -0500 )edit

I tested the this last night but I installed with puppet module install apache and it use the port 80 , try make a wget http://www.google.com to check if access for port 80 is working , about the offline version seems like the file is corrupted I will test it later at home.

Renan Vicente gravatar imageRenan Vicente ( 2014-04-29 10:22:59 -0500 )edit
1

Is there any way to make the offline version work? I'm behind sufficient proxies and firewalls at work that I'd much prefer to just be able to get through this tutorial offline.

Hsmarsh gravatar imageHsmarsh ( 2014-06-03 13:31:05 -0500 )edit

I'm seeing the same problem as @Hsmarsh: behind (authenticating) proxies so looking to use the offline modules, but getting the same error: gzip: stdin: not in gzip format I get the same error when trying to unzip them manually. Are these modules corrupt?

stainless gravatar imagestainless ( 2014-06-30 10:29:29 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-08-11 15:36:29 -0500

Pat gravatar image

The tarballs in the current as of 8/11/14 VM are broken. They're actually HTML files with a 302 redirect. Someone didn't check them after they downloaded them...

And the reason why the quest isn't showing as complete is that the version of puppetlabs-apache that's being installed (1.1.1) is missing the Modulefile that quest is looking in for its success criteria.

edit flag offensive delete link more

Comments

woolfie gravatar imagewoolfie ( 2014-09-04 14:06:31 -0500 )edit
0

answered 2014-09-22 13:14:15 -0500

Same problem. Downloaded file from: https://github.com/puppetlabs/puppetl...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-29 05:54:55 -0500

Seen: 869 times

Last updated: Apr 29 '14