Ask Your Question
1

New module release on the Forge. Clients still fetch the old ?

asked 2014-05-04 17:12:29 -0500

samircury gravatar image

updated 2014-05-04 23:42:36 -0500

spuder gravatar image

Hi,

Maybe I'm overlooking something basic, but I apparently successfully updated this module :

https://forge.puppetlabs.com/samircury/kvm

To version 1.2.0 but still :

[root@darkstar ~]# puppet module install samircury-kvm
Notice: Preparing to install into /etc/puppet/modules ...
Notice: Downloading from https://forge.puppetlabs.com ...
Notice: Installing -- do not interrupt ...
/etc/puppet/modules
└── samircury-kvm (v1.1.2)
[root@darkstar ~]# date
Sun May  4 15:05:34 PDT 2014

Tried in a "virgin" Docker container to make sure there were no caches, but still the same.

Any ideas? puppet module update claims it's up-to-date in 1.1.2.

Thanks, Samir

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2014-05-05 12:46:23 -0500

WhatsARanjit gravatar image

Please update your Modulefile with the correct version number. The Forge is getting confused.

edit flag offensive delete link more

Comments

I don't get it. The intended version is 1.2.0, and that seems to be right in the module file : version '1.2.0' -- that's the intended version I downloaded the tarball, and it's the same as in GitHub, right version.

samircury gravatar imagesamircury ( 2014-05-05 23:04:12 -0500 )edit
0

answered 2014-05-05 00:07:43 -0500

spuder gravatar image

updated 2014-05-05 00:10:07 -0500

I ran into a similar issue here:

Puppet enterprise is much more restrictive in updating modules than the open source version. If using puppet enterprise, you may need to contact the author to modify dependencies.

Try running the following commands

puppet module list

puppet config print module path

You can also try installing the module to a different path as a test

 puppet module install samircury-kvm --modulepath=/tmp
 puppet modle list --modulepath=/tmp

As a last resort, you could try the force option.

puppet module upgrade samircury-kvm --force --verbose

You can see all the options here:

 puppet help module upgrade
edit flag offensive delete link more

Comments

Tried all that(force, verbose), except a different module path, although a good idea, same result. After removing and installing in the default path, no luck still : [root@darkstar ~]# puppet module list /etc/puppet/modules ├── ghoneycutt-common (v1.1.0) ├── puppetlabs-stdlib (v4.1.0) └── samircury-kvm (v1.1.2)

samircury gravatar imagesamircury ( 2014-05-05 23:07:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-04 17:12:29 -0500

Seen: 140 times

Last updated: May 05 '14