Set listen_address for PuppetDB

asked 2014-05-05 15:45:44 -0600

looney1s gravatar image

updated 2014-05-05 16:36:48 -0600

spuder gravatar image

Hi,

I'm using version 3.2.2 of PE on RedHat 6.5 in AWS. I have installed separate Instances for the Puppet Master, PuppetDB, and the Puppet Console. If I login to the puppet-db, and I modify the postgresql.conf, and the jetty.ini files to bind to 0.0.0.0 or '*', everything works fine. Once the puppet agent runs on the db server, the configuration from the master is applied, and the puppet-db server is no longer reachable (port 5432 only) from the master or the console. I can still ping / nmap the puppet-db server and that port is not reachable.

So, I'd like to update the configuration stored on the master, to bind puppetdb to the correct interfaces. I have tried for over a week, and cannot figure out where the default listen_address comes from for the puppetlabs-pepuppetdb module. I have modified the /opt/puppet/share/puppet/modules/pepuppetdb/manifests/params.pp file and the /opt/puppet/share/puppet/modules/pe-postgresql/manifests/params.pp with no luck. It's like those options are even being listen to. Is there a different location these are stored in?

I found a change note from Ken Barber for fix "PDB-177 Replace ssl-host default with 0.0.0.0", that seems to fix my exact problem, but I'm unable to "puppet module upgrade puppetlabs-pe_puppetdb" and get the fixes.

Any help would be great! Thanks, Jason.

Example output:
[root@puppet-db puppet]# netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      1123/rpcbind
tcp        0      0 0.0.0.0:33587               0.0.0.0:*                   LISTEN      1141/rpc.statd
tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN      1451/sshd
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      1241/cupsd
tcp        0      0 0.0.0.0:5432                0.0.0.0:*                   LISTEN      1503/postmaster
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      1589/master
tcp        0      0 :::111                      :::*                        LISTEN      1123/rpcbind
tcp        0      0 :::8080                     :::*                        LISTEN      1168/java
tcp        0      0 :::8081                     :::*                        LISTEN      1168/java
tcp        0      0 :::22                       :::*                        LISTEN      1451/sshd
tcp        0      0 ::1:631                     :::*                        LISTEN      1241/cupsd
tcp        0      0 :::50523                    :::*                        LISTEN      1141/rpc.statd
udp        0      0 0.0.0.0:111                 0.0.0.0:*                               1123/rpcbind
udp        0      0 0.0.0.0:39798               0.0.0.0:*                               1141/rpc.statd
udp        0      0 0.0.0.0:631                 0.0.0.0:*                               1241/cupsd
udp        0      0 172.31.38.110:123           0.0.0.0:*                               1459/ntpd
udp        0      0 127.0.0.1:123               0.0.0.0:*                               1459/ntpd
udp        0      0 0.0.0.0:123                 0.0.0.0:*                               1459/ntpd
udp        0      0 0.0.0.0:893                 0.0.0.0:*                               1141/rpc.statd
udp        0 ...
(more)
edit retag flag offensive close merge delete

Comments

Did you change the database_host in params.pp too

Manula Waidyanatha gravatar imageManula Waidyanatha ( 2014-05-06 03:48:39 -0600 )edit